Wednesday, December 16, 2015

OpenWRT: one device, multiple routers.

Overview.

Commonly companies has many departments or sections that needs isolated networks, differents types of Internet access and internal routing protocols.
In this way, sometimes each department do its own war whitout a common solution that integrates all company services. The result of this lack of planification is a lot of under-exploited resources: duplicated switches, routers and a lot of wireless access points for each department.
This is, of course, the worst way to build and maintain an company network. A better way is to use the same devices for all services and isolate services in such devices. Isolate a LAN is as easy as to use VLAN in switches, but… What about isolate route tables, NAT or routing protocols? This post will try to give you a resource to do it this using OpenWRT on a single device.

Why OpenWRT.

There are thousands of routers with NAT and routing protocols. But, how many of them can isolate L3 or L4 IP services? not them all, anyway.
Cisco, Juniper, Fortigate, Mikrotik and most of other can do it, but generally they are expensive or don’t collects all requirements. OpenWRT can be a good alternative. Some of its advantages are:
  • built-in package manager that allows you to install packages from a software repository
  • In two years, you may need a new functionality that you have not thought about today. In other devices you must change the software version or buy a new device (some functionalities may be incompatibles).
    OpenWRT repository has thousands of available software packages you can install, try, and discard.
  • Hard development.
  • OpenWRT community is high active. Its software is constantly developing and updating packages.
  • Embedded.
  • OpenWRT needs less than 50Mb to be installed and once it’s running only the access to hard drive for writing configuration changes. It can be installed on a Compact Flash, a SD card or any plugable device such a USB. It doesn't need hard drive maintenance.
  • Customizable (scripting capable).
  • Like all other Linux based systems, almost its processes can be managed by using scripts. You can schedule or automate any job.
  • Runnable on any x86 hardware.

Scenario.

Like I had explain in the overview our scenario will be an enterprise with three departments: Red, Blue and Green. Each department have its own network with different offices in the same building, and each office has a different subnet. Each department has its own Internet provider and all of them use routing protocols for manage its subnets.

Software and hardware.

Obviously, we will use OpenWRT to do this, otherwise the title of this post would be a big mistake. There are more than one package we can use to solve each need, I had choose this ones:

For isolating departments lans: Vlan.

For isolating departments networks: namespaces. All process running within a namespace have their own work environment and are isolated and invisible for the others. Namespaces can contain interfaces. When an interface is linked to a namespace it’s invisible for other namespaces.

For routing protocols: BIRD daemon. BIRD is a powerful routing daemon. I had used Quagga for many years, but in the last few years I had needed to migrate to BIRD because it can do more things in an easier way. Run several instances of Quagga is a bit more difficult than running several instances of BIRD. All you need to run a second instance of BIRD is a second configure file and a second PID file.

OpenWRT can run in a wide range of commercial routers and in lot of X86 based hardware (PC, PCengines, Raspberry Pi, etc) as well. I will use a VirtualBox virtual machine.


Configuration.

It isn't necessary to explain how to download, compile and install OpenWRT, because it is widely explained in its web page and in many other blogs. I want to bore you with configurations and scripts, but not with installations. The only thing you must know is to enable namespaces in the kernel before compile:

CONFIG_KERNEL_NET_NS=yes

Namespaces, vlans, IP address.
Let's start working!
First of all we want to create vlan. If you had managed a Linux system before, you probably know how to do it. We will assign vlan 100 for Red department, vlan 150 for Blue department and vlan 200 for Green department:

vconfig add eth1 100
vconfig add eth1 150
vconfig add eth1 200


Now we want to create the namespaces.

ip netns add red
ip netns add blue
ip netns add green

Link the vlan to its namespace:

ip link set eth1.100 netns red
ip link set eth1.150 netns blue
ip link set eth1.200 netns green

For viewing a list of namespaces running in the system simply run:

ip netns

To execute a command inside the namespace:

ip netns exec red ip addr


And configure IP address for each interface:

ip netns exec red ifconfig eth1.100 192.168.100.1 netmask 255.255.255.0
ip netns exec blue ifconfig eth1.150 192.168.150.1 netmask 255.255.255.0
ip netns exec green ifconfig eth1.200 192.168.200.1 netmask 255.255.255.0

You can try to ping from a namespace to others, but you will see you cannot:

Init script.
To make our life easier, we can use OpenWRT UCI configuration format and a script that loads it to make all configurations.

The configuration file can be something like this:

config namespace 'red_namespace'
        option name 'red’
        option vlan '100'
        option ip '192.168.100.1/24’

config namespace 'blue_namespace'
        option name 'blue’
        option vlan '150'
        option ip '192.168.150.1/24’

config namespace 'green_namespace'
        option name 'green’
        option vlan '200'
        option ip '192.168.100.1/24’

And the script:

config_namespaces(){
        config_get name "$1" name
       config_get ip "$1" ip
        config_get vlan "$1" vlan

        logger "loaded configurtion for namespace "$name

        if [ ! -f /var/run/netns/$name ]; then
                ip netns add $name
                logger "adding namespace "$name
        else
                logger "namespace "$name" alredy exists"
        fi


        logger "new vlan eth0."$vlan."
        vconfig add eth0 $vlan

        logger "link vlan eth0."$vlan " to namespace "$name
        ip link set eth0.$vlan netns $name

       logger "setting IP to vlan eth0."$vlan
        ip netns exec $name ip addr add $ip dev eth0.$vlan
        ip netns exec $name ifconfig eth0.$vlan up


}

start() {
 
        config_load namespaces
        config_foreach config_namespaces namespace
}

Obviously, we must assign execution permissions and enable the script to run at boot time:

chmod ug+x
/etc/init.d/namespaces enable

BIRD4 daemon.

BIRD4 daemon is in OpenWRT repositories, so install it is as simple as use opkg package manager:


opkg install bird4 birdc4

Default install will create a script in /etc/init.d for run the daemon at boot time. If we don't want to use it we must disable

/etc/init.d/bird4 disable

if we want to run three instances of BIRD4 daemon, one per namespace. We will place de configuration files in /etc/bird4.d/namespace.bird4.conf and PID file in /var/run/namespace.bird4.pid. Also BIRD4 client (bird4c) needs a socket file for communicate with the daemon, so we will place this file in /var/run/namespace.bird4.ctl

ip netns exec red bird4 -c /etc/bird4.d/red.bird4.conf -P /var/run/red.bird4.pid -s /var/run/red.bird4.ctl

We can update the init script to run BIRD4 if the configuration file has the line “option bird ‘yes’” adding these lines to function config_namespaces():

        config_get_bool bird "$1" bird


        if [ $bird ]; then
        logger “Running BIRD4 in namespace “$name
                ip netns exec $name bird4 -c /etc/bird4.d/$name.bird4.conf -P /var/run/$name.bird4.pid -s /var/run/$name.bird4.ctl
        fi

if you want to connect bird4 client to a daemon, you must use the CTL socket placed in /var/run. For example:

birdc4 -s /var/run/green.bird4.ctl

IPTables.

Now probably you want to add an external interface, and you may want to use NAT and firewall between external and internal networks. We can use the same method: add a Vlan to external interface, configure external IP and run a script that configure IPTables rules.

As it is the same procedure, I will summarize the steps and show the full script code in the next section

Final config file and script.

The final config file can be someting like this:

config namespace 'red_namespace'
        option name 'red'
        option internalVlan '100'
        option internalIP '192.168.100.1/24'
        option bird 'true'
        option externalVlan '1100'
        option externalIP '10.0.0.2/30'
        option defaultGW '10.0.0.1'
        option iptables 'true'


config namespace 'blue_namespace'
        option name 'blue'
        option internalVlan '150'
        option internalIP '192.168.150.1/24'
        option bird 'true'
        option externalVlan '1150'
        option externalIP '10.20.0.2/30'
        option defaultGW '10.20.0.1'
        option iptables 'true'


config namespace 'green_namespace'
        option name 'green'
        option internalVlan '200'
        option internalIP '192.168.100.1/24'
        option bird 'true'
        option externalVlan '1200'
        option externalIP '10.50.0.2/30'
        option defaultGW '10.50.0.1'
        option iptables 'true'


And the final script:

#!/bin/sh /etc/rc.common


START=70
STOP=15


config_namespaces(){

        config_get name "$1" name
        config_get internalIP "$1" internalIP
        config_get internalVlan "$1" internalVlan
        config_get externalIP "$1" externalIP
        config_get externalVlan "$1" externalVlan
        config_get defaultGW "$1" defaultGW
        config_get_bool bird "$1" bird
        config_get_bool iptables "$1" iptables

        logger -t "Namespaces Configuration" "loaded configurtion for namespace "$name


        #
        # If namespace already exists do not add it.
        #


        if [ ! -f /var/run/netns/$name ]; then
                ip netns add $name
                logger -t "Namespaces Configuration" "adding namespace "$name
        else
                logger -t "Namespaces Configuration" "namespace "$name" alredy exists"
        fi

        #
        # Add Vlan for LAN access (internal Vlan).
        #

        logger -t "Namespaces Configuration" "new vlan eth0."$internalVlan
        vconfig add eth0 $internalVlan

        #
        # Link internal Vlan to namespace
        #

        logger -t "Namespaces Configuration" "link vlan eth0."$internalVlan " to namespace "$name
        ip link set eth0.$internalVlan netns $name

        #
        # Add IP address to internal Vlan. After this, up it.
        #

        logger -t "Namespaces Configuration" "setting IP to vlan eth0."$internalVlan
        ip netns exec $name ip addr add $internalIP dev eth0.$internalVlan
        ip netns exec $name ifconfig eth0.$internalVlan up

        #
        # If option "bird" is enabled in configuration file, run BIRD4.
        #

        if [ $bird ]; then
                logger -t "Namespaces Configuration" "Running BIRD4 in namespace "$name
                ip netns exec $name bird4 -c /etc/bird4.d/$name.bird4.conf -P /var/run/$name.bird4.pid -s /var/run/$name.bird4.ctl
        fi

        #
        # If externalVlan is enabled in configuration file, add WAN vlan (external access).
        # Then link it to namespace and configure its IP address.
        # Then add a default route.
        #

        if [ externalVlan ]; then
                logger -t "Namespaces Configuration" "new vlan eth1."$externalVlan
                vconfig add eth1 $externalVlan

                logger -t "Namespaces Configuration" "link vlan eth1."$externalVlan " to namespace "$name
                ip link set eth1.$externalVlan netns $name

                logger -t "Namespaces Configuration" "setting IP to vlan eth1."$externalVlan
                ip netns exec $name ip addr add $externalIP dev eth1.$externalVlan
                ip netns exec $name ifconfig eth1.$externalVlan up

                ip netns exec $name ip route add default via $defaultGW
        fi

        #
        # If iptables is enabled in configuration file, run a script that has iptables rules.
        #

        if [ $iptables ]; then
                logger -t "Namespaces Configuration" "Running IPTables rules in namespace "$name
                ip netns exec $name /etc/iptables.d/$name.iptables.sh
        fi

}

start() {

        config_load namespaces
        config_foreach config_namespaces namespace
}

I hope you fun with this post as I had fun.
SEE US IN NEXT POST!

Monday, November 9, 2015

Securing your Mikrotik access

My first entry in the blog will explain how to secure access to a Mikrotik device. In order to do this we will use three methods:
  • Disable unnecessary protocols.
  • Firewall filters:
    • Port knocking technique.
    • Detection and filter of force brute attacks technique.
We are going to use the following scenario:

The Mikrotik device have three hypothetical interfaces:
  • ether1: WAN interface. It has a public IP address and, of course, it has Internet access.
  • ether2: LAN interface dedicated to user network. In this interface we want to allow manager access, but we want to make the access safe anyway.
Note: Make this changes can be dangerous and you can loose the access to the device, so you probably want to make it in Mikrotik safe mode.


First method: Make Mikrotik listen only for needed services.
Mikrotik can disable the protocols that you don’t need in ip service menu, so the first step is configure them. In this example we want to disable all manage protocols but SSH (the device will only listen for SSH and drops any other request).

/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh address=10.0.0.0/24
set api disabled=yes
set winbox disabled=yes
set api-ssl disabled=yes



And this is all about this method.

Second method: Port Knocking.
This is a little more interesting section. This is the goal: SSH port is disabled by default. To enable it you must to knock two doors. Knock a door is as easy as send a well known formatted packet (in this example first door opens when the device receive a TCP packet in port 2500 and second door opens when the device receive a TCP packet in port 2600). After this you can open a SSH session.
Port knocking prevents from port scanning techniques, because SSH port is closed until somebody knocks the doors.

Make sure you read the complete section before apply any command because its order is important to ensure you don’t loose the connection to the device you are configuring.

Let's go!

In first step, we disable any kind of traffic that has not been previously stablished:

/ip firewall filter
add chain=input connection-state=established,related
add action=drop chain=input

Print command should show something like this:

0 chain=input action=accept connection-state=established,related log=no log-prefix=""
1 chain=input action=drop log=no log-prefix=""

After this, in second step, we can add a rule that implement the first knock:

add chain=input connection-state=new dst-port=2500 protocol=tcp action=add-src-to-address-list address-list=DOOR1 address-list-timeout=30s log=no log-prefix="" place-before=1

The only thing this rule do is adding the IP address source that had send a TCP packet with destination port 2500 to an address list called “DOOR1” during 30 seconds. Cause Mikrotik applies rules in order, this rule must be applied before the rule that drops all incoming traffic.

0 chain=input action=accept connection-state=established,related log=no log-prefix=""
1 chain=input action=add-src-to-address-list connection-state=new protocol=tcp address-list=DOOR1 address-list-timeout=30s dst-port=2500 log=no log-prefix=""
2 chain=input action=drop log=no log-prefix=""

The second knock only occurs after the first one. Do this is as easy as add a new condition to rule: source IP must be in address-list “DOOR1”:

add chain=input connection-state=new dst-port=2600 protocol=tcp src-address-list=DOOR1 action=add-src-to-address-list address-list=DOOR2 address-list-timeout=2m log=no log-prefix="" place-before=2

I have incremented the timeout because sometimes I mistake the device password and I need several tries.

And finally, the SSH access:

add chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=DOOR2 log=no log-prefix="" place-before=3

The print command must look like this:

0 chain=input action=accept connection-state=established,related log=no log-prefix="" 1 chain=input action=add-src-to-address-list connection-state=new protocol=tcp address-list=DOOR1 address-list-timeout=30s dst-port=2500 log=no log-prefix=""
2 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=DOOR1 address-list=DOOR2 address-list-timeout=2m dst-port=2600 log=no log-prefix=""
3 chain=input action=accept connection-state=new protocol=tcp src-address-list=DOOR2 dst-port=22 log=no log-prefix=""
4 chain=input action=drop log=no log-prefix=""

Now a port scan will be useless:



You can knock with command "nmap -PN --host_timeout 201 --max-retries 0 -p 2500 10.0.0.1". I will use a simple ssh access with destination port 2500.
And this is an access example:



Ok. A bit further away. What about if you think “I only need port knocking on WAN interface, not on LAN interface"?. It's as easy as adding a rule that places in DOOR2 the access that comes from LAN interface:

add chain=input connection-state=new dst-port=22 in-interface=ether2 action=add-src-to-address-list address-list=DOOR2 address-list-timeout=1s log=no log-prefix="" protocol=tcp place-before=3

You can add a list of ACCESS_WHITELIST to this rule.

Extra security configuration: detect and filter port scanning. Port knocking can be a good way to make your device access safe, but you can go a step further away. There is another way to detect intrusions tries: filter the port scanning.
From Mikrotik wiki: port scan detection. In order to integrate this configuration with the rest of them you can place the rule before the port knocking rules.

add chain=input protocol=tcp psd=21,3s,3,1
action=add-src-to-address-list address-list=ACCESS_BLACKLIST address-list-timeout=30m log=no log-prefix="" place-before=1

And a rule that drops the traffic from hosts listed in “ACCESS_BLACKLIST”.

add chain=input action=drop port=22 protocol=tcp src-address-list=ACCESS_BLACKLIST place-before=5

The output of print command:

0 chain=input action=accept connection-state=established,related log=no log-prefix=""
1 chain=input action=add-src-to-address-list protocol=tcp psd=21,3s,3,1 address-list=ACCESS_BLACKLIST address-list-timeout=30m log=no log-prefix=""
2 chain=input action=add-src-to-address-list connection-state=new protocol=tcp address-list=DOOR1 address-list-timeout=30s dst-port=2500 log=no log-prefix=""
3 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=DOOR1 address-list=DOOR2 addresslist-timeout=2m dst-port=2600 log=no log-prefix=""
4 chain=input action=add-src-to-address-list connection-state=new protocol=tcp address-list=DOOR2 address-list-timeout=1s in-interface=ether2 dst-port=22 log=no log-prefix=""
5 chain=input action=drop protocol=tcp src-address-list=ACCESS_BLACKLIST port=22 log=no log-prefix=""
6 chain=input action=accept connection-state=new protocol=tcp src-address-list=DOOR2 dst-port=22 log=no log-prefix=""
7 chain=input action=drop log=no log-prefix=""

A port scan test on WAN interface:




The address list with the source IP address of the port scanner:




A try of access after a port scan:




And the result: SSH connection tries will be dropped




Third method: detect and filter brute force attacks.

Imagine a very intelligent attacker had obtained the format of the packets for knocking the doors. He will try to probe a force brute attack in order to obtain the device user and password.
This method assumes that more than three tries of authentication in less than a minute is an attack (or a very clumsy operator that needs to be punished). For each new connection to SSH port we will add the source IP to an additional address-list (ACCESS_TRY_1, ACCESS_TRY_2 and ACCESS_TRY_3). After this, the next try will be considered as an attack and will be dropped.

After you have knocked two doors, your IP must be in address-list “DOOR2”, so we must change the rule 6 to something like this:


set 6 connection-state=new port=22 protocol=tcp src-address-list=DOOR2 action=add-src-to-address-list address-list=ACCESS_TRY_1 address-list-timeout=20s place-before=5
OK. The second try will be similar to the first, but it will check the address-list ACCESS_TRY_1. Must be placed before the rule that register the first try, because if not, this rule will be executed immediately after and will register the first try as a new second try (Remember: Mikrotik matches the rules in order). We will use the same procedure with third try, but the address list that we will add the source IP will be ACCESS_BLACKLIST.

The result must be like this:

0 chain=input action=accept connection-state=established,related log=no log-prefix=""
1 chain=input action=add-src-to-address-list protocol=tcp psd=21,3s,3,1 address-list=ACCESS_BLACKLIST address-list-timeout=30m log=no log-prefix=""
2 chain=input action=add-src-to-address-list connection-state=new protocol=tcp address-list=DOOR1 address-list-timeout=30s dst-port=2500 log=no log-prefix=""
3 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=DOOR1 address-list=DOOR2 address-list-timeout=2m dst-port=2600 log=no log-prefix=""
4 chain=input action=add-src-to-address-list connection-state=new protocol=tcp address-list=DOOR2 address-list-timeout=1s in-interface=ether2 dst-port=22 log=no log-prefix=""
5 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=ACCESS_TRY_3 address-list=ACCESS_BLACKLIST address-list-timeout=20s port=22 log=no log-prefix=""
6 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=ACCESS_TRY_2 address-list=ACCESS_TRY_3 address-list-timeout=20s port=22 log=no log-prefix=""
7 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=ACCESS_TRY_1 address-list=ACCESS_TRY_2 ddress-list-timeout=20s port=22 log=no log-prefix=""
8 chain=input action=add-src-to-address-list connection-state=new protocol=tcp src-address-list=DOOR2 address-list=ACCESS_TRY_1 address list-timeout=20s port=22 log=no log-prefix=""
9 chain=input action=drop protocol=tcp src-address-list=ACCESS_BLACKLIST port=22 log=no log-prefix=""
10 chain=input action=accept connection-state=new protocol=tcp src-address-list=DOOR2 dst-port=22 log=no log-prefix=""
11 chain=input action=drop log=no log-prefix=""


an example of a brute force attack:



And a bit further again: email when your router detect and filter an attack. You need only two configurations: “/tool e-mail” and “system loggin”. In addition you can add a prefix to log line.

/ip firewall filter
set 5 log=yes log-prefix="IP BACKLISTED"
/system logging action
add email-to=somebody@example.com name=mail target=email
/system logging
add action=mail prefix=**IP-BANNED** topics=firewall

Finally, the complete script that resume all the post is the following:

/ip firewall filter
add chain=input connection-state=established,related
add chain=input protocol=tcp psd=21,3s,3,1 \
action=add-src-to-address-list address-list=ACCESS_BLACKLIST address-list-timeout=30m
add chain=input connection-state=new dst-port=2500 protocol=tcp \
action=add-src-to-address-list address-list=DOOR1 address-list-timeout=30s
add chain=input connection-state=new dst-port=2600 protocol=tcp src-address-list=DOOR1 \
action=add-src-to-address-list address-list=DOOR2 address-list-timeout=2m
add chain=input connection-state=new dst-port=22 in-interface=ether2 protocol=tcp \
action=add-src-to-address-list address-list=DOOR2 address-list-timeout=1s
add chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=ACCESS_TRY_3 \
action=add-src-to-address-list address-list=ACCESS_BLACKLIST address-list-timeout=20s \
log=yes log-prefix="IP BACKLISTED"
add chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=ACCESS_TRY_2 \
action=add-src-to-address-list address-list=ACCESS_TRY_3 address-list-timeout=20s
add chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=ACCESS_TRY_1 \
action=add-src-to-address-list address-list=ACCESS_TRY_2 address-list-timeout=20s
add chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=DOOR2 \
action=add-src-to-address-list address-list=ACCESS_TRY_1 address-list-timeout=20s
add action=drop chain=input port=22 protocol=tcp src-address-list=ACCESS_BLACKLIST
add chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=DOOR2
add action=drop chain=input

/system logging action
add email-to=somebody@example.com name=mail target=emai

/system logging
add action=mail prefix=**IP-BAN** topics=firewall
I hope you enjoy it!

Friday, November 6, 2015

Presentation

I have learned very much reading in blogs and other web resources. I can say that the most I have learned about my professional knowledge is obtained because a lot of people have share their knowledge.

I think it’s time now to share a bit of my own knowledge, and this is the way I have selected for do it.


I'm not interested in earning money with this, but insert ads with adSense is free and easy, so I though that the money that I could earn (if some) could be dedicated to a NGO.

I hope it is interesting for you!